UP3.0 Hotfix Patch

Meeting place for IL2 fans and those using Inspire's dedicated IL2 server.

Moderators: CadMan, Smokey Joe

UP3.0 Hotfix Patch

Postby beepee » Wed Jul 01, 2015 2:22 am

Hey all.

I have not looked at the SAS site for awhile, but I found this:
http://www.sas1946.com/main/index.php/topic,46133.0.html

It basically fixes some bugs and updates UP3.0RC4 with newer bits and pieces.

As far as I can tell, it is enabled in JSGME mod switcher (just like UP etc).

I have not looked much further into it at this point.

The only real downside is that (once again), if someone tried to join a hosted game and they did not have this patch enabled they would not be able to join.
User avatar
beepee
 
Posts: 889
Joined: Fri Dec 31, 2010 8:32 pm
Location: Otaua.

Re: UP3.0 Hotfix Patch

Postby Woody01 » Wed Jul 01, 2015 8:00 pm

Sounds like it fixes all the little gripes we have had with an otherwise awesome version.
Think Ill look into it, hell we haven't had a version change for years now :shock:
User avatar
Woody01
 
Posts: 2671
Joined: Tue Mar 14, 2006 8:09 pm
Location: Rangiora

Re: UP3.0 Hotfix Patch

Postby Woody01 » Wed Jul 01, 2015 8:39 pm

I have installed it in a backup game folder and it seems really good. Need to test it online but I think this could be the fix we have been looking for!
It sounds like inter version games will work also for the first time ever. We will see this Sunday!

Thanks Beeps! Great find mate _b
User avatar
Woody01
 
Posts: 2671
Joined: Tue Mar 14, 2006 8:09 pm
Location: Rangiora

Re: UP3.0 Hotfix Patch

Postby HunHunter » Thu Jul 02, 2015 6:49 pm

Using the new 3d model for the typhoon is a big plus for me, I had avoided making missions around it for the fact that the old one was terrible.

Pity they didnt add the Do17 or B-26 but you cant have everything.
HunHunter
 
Posts: 1010
Joined: Fri Dec 24, 2004 3:35 pm

Re: UP3.0 Hotfix Patch

Postby Woody01 » Thu Jul 02, 2015 8:07 pm

Oh!
Does that mean you are making new missions around the Tiffy?
Please?
User avatar
Woody01
 
Posts: 2671
Joined: Tue Mar 14, 2006 8:09 pm
Location: Rangiora

Re: UP3.0 Hotfix Patch

Postby Woody01 » Fri Jul 03, 2015 8:56 pm

Maybe hold off for more testing guys, last night it seemed fine, tonight it is just crashing the PC.
might be something I have done wrong but I followed the instructions. It seems to have issue with the RC4 mod and the gurner effects...
User avatar
Woody01
 
Posts: 2671
Joined: Tue Mar 14, 2006 8:09 pm
Location: Rangiora

Re: UP3.0 Hotfix Patch

Postby beepee » Sun Jul 05, 2015 1:53 am

It could well be the Gurners causing the conflict.

My days off are Monday and Tuesday so I will check it out then sometime.

I will post something in the SAS thread about it Woody.
User avatar
beepee
 
Posts: 889
Joined: Fri Dec 31, 2010 8:32 pm
Location: Otaua.

Re: UP3.0 Hotfix Patch

Postby beepee » Mon Jul 06, 2015 3:41 am

I posted in the SAS forums and recieved this reply:

Yes beeps, it's quite likely that Gurners' FC mod causes issues with this Patch Pack.
Let me briefly explain the reason why:

When UP3 has been released, it contained an enhanced version of Zuti's MDS mod which, regardless how much we like it, unfortunately was completely obfuscated in Java Code.

As a result, UP3 was mostly out of reach for modding.

Nevertheless a few modders took up the task and created UP3 compatible versions of their mods, actually by "try and error" name mangling of the function calls into these obfuscated MDS classes.

There's a handful mods out there being able to "plug in" into such an "original" obfuscated MDS. Gurner and UV3 are the two examples that come to my mind at the moment.

Initially with the "unobfuscated UP3" mod which is now part of our patch packs, we provided a version of Zuti's MDS for UP3 which comes without those obfuscation caveats, making it possible for modders to mod UP3 in the normal way.

This however causes those few mods which have been bound to the obfuscated classes to throw errors.

That much for the bad news.
The good news is that your post actually gave me an idea. A starting point which could eventually lead us to a Patch Pack which can be used in both ways, with classes compiled against the unobfuscated MDS and the obfuscated one.
I'll see what I can do about this in the coming weeks and will let you know as soon as I see clearly how much this is feasible.

For the time being, your classmate can try the classes from the DBW version of Gurners' FX mod, just by copying the hashed classfiles from that version into the "#UP#" folder (instead of "#DBW"), overwriting the existing ones in there. This might or might not work, but it's worth a try.


So, hopefully Storebor (Mike) can work his magic on it.

What he has suggested with DBW classfiles might be worth a crack too, I will try it out on Tuesday.
User avatar
beepee
 
Posts: 889
Joined: Fri Dec 31, 2010 8:32 pm
Location: Otaua.

Re: UP3.0 Hotfix Patch

Postby beepee » Wed Jul 08, 2015 8:06 am

So I gave her a crack and found the same conflict with Gurners.

Even with the DBW classfiles it was unstable and eventually crashed.

I might test it again on my next days off. But for now it looks like either the hotfix and no gurners, or the gurners and no hotfix.
User avatar
beepee
 
Posts: 889
Joined: Fri Dec 31, 2010 8:32 pm
Location: Otaua.

Re: UP3.0 Hotfix Patch

Postby Woody01 » Wed Jul 08, 2015 8:08 pm

Hey good on you Beepee _b Thanks for finding that out mate.
Have to wait and see I guess, I don't think I could give up Gurners effects, they are just too bloody good, but there is hope if he will look into it.

Cheers mate.
User avatar
Woody01
 
Posts: 2671
Joined: Tue Mar 14, 2006 8:09 pm
Location: Rangiora


Return to IL2

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron